Yesterday (15 January 2026), we experienced degraded performance affecting Azure Virtual Desktop (AVD) logins, with many users experiencing delayed or failed session starts. Our investigation indicates this was triggered by a higher demand on an underlying storage component in Azure. This increased activity led to platform throttling, which impacted AVD connectivity. We have taken immediate steps to stabilise the service, continue close monitoring, and will publish a more detailed Root Cause Analysis once our full review is complete.
Posted Jan 16, 2026 - 12:46 UTC
Resolved
The service disruption reported yesterday has now been resolved.
Our teams implemented system changes overnight and carried out a controlled restart to restore normal service. We are continuing to monitor performance closely to ensure stability.
We apologise for the disruption and thank you for your patience. A short incident summary will be shared in due course.
Posted Jan 16, 2026 - 09:56 UTC
Update
We are continuing to monitor the recent changes. All Plus2 logins have returned to acceptable ranges.
Posted Jan 16, 2026 - 07:35 UTC
Update
We will be pushing out further updates this evening to help resolve the latency issues the platform is experiencing
Posted Jan 15, 2026 - 21:45 UTC
Update
We wanted to provide an update on the current issue. Plus2 is coming back online, however, we are still seeing some connection and performance issues. Our teams continue to investigate this as a matter of highest priority, and we will provide further updates as soon as more information is available.
Posted Jan 15, 2026 - 17:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2026 - 15:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 15, 2026 - 15:30 UTC
Update
Plus2 connections are starting to recover
Posted Jan 15, 2026 - 15:20 UTC
Update
We are currently experiencing high levels of failed connections
Posted Jan 15, 2026 - 15:00 UTC
Identified
We are currently still investigating high latency with connections to Plus2 AVD. Currently the has been mitigated to increase the speed to connect and login but additional changes are still being investigated which could result in temporary disconnections for some users.
Posted Jan 15, 2026 - 14:17 UTC
Update
we are continuing to investigate the cause of this issue.
Posted Jan 15, 2026 - 13:12 UTC
Update
We are continuing to investigate this issue. Currently we are experiencing high levels of traffic to the Plus2 profiles which is causing throttling on the connections into the platform. Connections are still working but are experiencing large levels of latency.
Posted Jan 15, 2026 - 12:43 UTC
Update
we are continuing to investigate the cause of this issue.
Posted Jan 15, 2026 - 11:43 UTC
Update
we are continuing to investigate the cause of this issue.
Posted Jan 15, 2026 - 10:15 UTC
Update
We believe we have identified the cause, we are continuing to investigate
Posted Jan 15, 2026 - 09:16 UTC
Update
We are continuing to investigate this issue.
Posted Jan 15, 2026 - 09:01 UTC
Investigating
We are aware of an issue affecting the ability to log in to AVD to access Plus2. We are currently investigating
Posted Jan 15, 2026 - 08:35 UTC
This incident affected: Gladstone Cloud (Plus2 (AVD)).