Email Delays

Incident Report for Gladstone Software

Resolved

This incident has been resolved.
Posted Jun 14, 2026 - 18:28 UTC

Monitoring

We are currently tracking an incident with one of our 3rd parties responsible for email delivery. This may impact emails being sent from the Go platform, BPM & Gladstone360 which will result in some users seeing a delay in email delivery.

We are monitoring the incident closely.
Posted Jun 14, 2026 - 17:18 UTC
This incident affected: Gladstone Cloud (GoBook, GoJoin, Signature Applications).