Cloudflare Global Network experiencing issues

Incident Report for Gladstone Software

Postmortem

Service Update: Cloudflare Network Outage – 18 November 2025

On 18 November 2025, Gladstone’s services were affected by a global issue with Cloudflare, one of our key partners that helps keep our systems secure and performing reliably. The disruption lasted about 5 hours, during which you experienced slower performance and intermittent or even complete loss of access to certain services.

Cloudflare has now fully resolved the issue and published a detailed explanation of what occurred, which you can read here: Cloudflare’s incident report.

Our Next Steps

While this incident was caused by an upstream provider, we’re reviewing how we can reduce the impact of similar events in the future.

We appreciate your patience and understanding as we continue strengthening our systems for even greater reliability.

Posted Nov 19, 2025 - 12:14 UTC

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 19:28 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 19:28 UTC

Update

Cloudflare continue to monitor the system through recovery and they are seeing services return to normal.
Posted Nov 18, 2025 - 17:29 UTC

Update

While service has improved, the Cloudflare team is continuing to focus on restoring service post-fix. They are mitigating several issues that remain post-deployment.
Posted Nov 18, 2025 - 16:11 UTC

Monitoring

Cloudflare have implemented a fix and they believe the incident is now resolved. They are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 14:48 UTC

Investigating

Cloudflare are continuing working on restoring services.
Posted Nov 18, 2025 - 13:46 UTC

Identified

Cloudflare has identified the issue impacting service and is working to implement a fix.
Posted Nov 18, 2025 - 13:15 UTC

Update

Cloudflare are seeing services recover, but you may continue to see higher-than-normal error rates at this time.
Posted Nov 18, 2025 - 12:32 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:12 UTC

Update

We are aware of an issue impacting our systems due to a Cloudflare network issue
https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 11:55 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 11:53 UTC
This incident affected: Gladstone Cloud (Single API, GoBook, GoJoin, Plus2 (AVD), Signature Applications, Gladstone Drive Portal), Signature Hosting (360 Servers, SQL Servers), and Cloudflare London, United Kingdom - (LHR), Cloudflare Manchester, United Kingdom - (MAN).